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1. Overview 
This guide walks you through every step needed to install, configure, and run the Extreme ERP 
source code — from setting up your development tools to deploying a production-ready system on 
your own server or cloud infrastructure. 

The system is built on ASP.NET Web Forms (.NET Framework 4.7.2) with a Microsoft SQL 
Server database and IIS as the web server. All three components are required. 

 

What You Will Need 

Before you begin, ensure you have: 

• A Windows machine (Windows 10/11 for development, Windows Server for production) 
• Administrator access to install software 
• The Extreme Office source code package (downloaded from your purchase) 
• An internet connection for downloading free tools 

 

Estimated Setup Time 

Component Minimum Recommended 

Development PC 30 – 60 minutes First time with all tool installs 

Staging / Testing 
Server 

1 – 2 hours Including IIS and SQL configuration 

Production Cloud 
Server 

2 – 4 hours Including SSL and domain setup 
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2. System Requirements 

Production / Live Server Requirements 

Component Minimum Recommended 

Operating System Windows 10 (64-bit) or Server 
2019 

Windows Server 2022 

Web Server IIS 10.0 IIS 10.0 

.NET Framework 4.7.2 4.7.2 (exact — do not use 5+) 

Database SQL Server 2019 Express SQL Server 2019 / 2022 Standard 

Crystal Reports 
Runtime 

SAP CR 13.0.4000 SP29 SAP CR 13.0.4000 SP29 (exact) 

RAM 4 GB 8 – 16 GB 

Storage 20 GB 100 GB (for data growth) 

CPU 2 Core 4 Core 

 

  ⚠  WARNING    Minimum OS for live/production use is Windows 10 (64-bit) or Windows Server 2019. 
Earlier versions such as Windows 7, Windows 8.1, or Windows Server 2016 are not supported for 
production deployment. 

 

  ⚠  WARNING    Crystal Reports version must be SAP Crystal Reports Runtime 13.0.4000 SP29 exactly. 
Do not install an older or newer service pack — version mismatches will cause all reports to fail silently or 
throw runtime errors. 

 

Development Environment (Your PC) 

Component Minimum Recommended 

Operating System Windows 10 (64-bit) Windows 10 / 11 (64-bit) 

Visual Studio 2019 (Community) Visual Studio 2022 Community (free) 

SQL Server SQL Server 2019 Express 
(free) 

SQL Server 2019 Developer (free) 

SQL Server Mgmt 
Studio 

SSMS 18+ SSMS 19+ (free download) 

Crystal Reports 
Runtime 

SAP CR 13.0.4000 SP29 SAP CR 13.0.4000 SP29 (exact) 

.NET Framework 
SDK 

4.7.2 Included automatically with Visual Studio 



Extreme Office ERP  —  Setup & Deployment Guide Alwajeez Tech 

alwajeeztech.com  |  sales@alwajeeztech.com  |  +966 55 894 7166 Page 6 

 

  ⚠  WARNING    Do NOT use .NET 5, .NET 6, .NET 7, .NET 8, or .NET Core. This project targets the 
classic .NET Framework 4.7.2. These are entirely different runtime environments and are not compatible. 
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3. Step-by-Step Setup 

1 
Extract the Source Code Package 
Unzip the downloaded package to a permanent location on your hard drive. 

 

  💡 TIP    Avoid paths with spaces or special characters. Use a simple path like 
C:\Projects\ExtremeOffice 

 

 
Recommended location: 
  C:\Projects\ExtremeOffice\ 
  
The folder should contain: 
  /app/                          ← Main ASP.NET web application 
  /app/xyz_DB.bak       ← SQL Server database backup (restore this!) 
  /app/CoreAccBasicsScript.sql   ← Alternative SQL script (if .bak restore 
fails) 
  /app/Web.config               ← Application configuration 
  /app/App_Code/                ← Shared C# business logic classes 
  /app/bin/                     ← Compiled libraries (Crystal Reports etc.) 
  /app/bin/CRRuntime/           ← Crystal Reports 13.0.4000 SP29 installer 

 

 

2 
Install Required Tools 
Install Visual Studio and SQL Server if you have not already done so. 

 

2a. Visual Studio 2022 Community (Free) 

1. Go to: https://visualstudio.microsoft.com/vs/community/ 
2. Download and run the installer 
3. During installation, select the workload: ASP.NET and web development 
4. Ensure .NET Framework 4.7.2 targeting pack is checked 
5. Complete installation (may take 20–40 minutes) 

 

2b. SQL Server 2019 Express (Free) 

6. Go to: https://www.microsoft.com/en-us/sql-server/sql-server-downloads 
7. Download SQL Server 2019 Express 
8. Run the installer and choose Basic installation 
9. Note the Server name shown at the end — you will need it (e.g. .\SQLEXPRESS) 

 

2c. SQL Server Management Studio (Free) 
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10. Go to: https://learn.microsoft.com/en-us/sql/ssms/download-sql-server-management-
studio-ssms 

11. Download and install the latest SSMS 
12. Launch SSMS and connect to your SQL Server instance to verify the install 

 

3 
Restore the Database Backup 
Use SQL Server Management Studio to restore .bak — this is the fastest and most reliable 
way to get a fully seeded database. 

 

The package includes a ready-made SQL Server backup file: xyz_DB.bak. Restoring this file 
gives you the complete database schema, all stored procedures, views, and demo seed data in 
one step — no need to run any SQL scripts manually. 

 

Method A: Restore via SSMS GUI (Recommended) 

13. Locate the backup file in your extracted package: 
 

 
C:\Projects\ExtremeOffice\app\xyz_db.bak 

 

14. Open SQL Server Management Studio (SSMS) 
15. Connect to your SQL Server instance using Windows Authentication or your SA login 
16. In Object Explorer, right-click Databases → Restore Database… 
17. In the Restore Database dialog, select Device as the source 
18. Click the … (Browse) button next to the Device field 
19. In the Select backup devices dialog, click Add 
20. Navigate to and select: xyz_db.bak — then click OK 
21. Back in the Restore Database dialog, the backup set details will populate automatically 
22. In the Destination section, set the Database name to: Xyz_db 
23. Click the Options page on the left side panel 
24. Check: Overwrite the existing database (WITH REPLACE) — required if restoring over an 

existing copy 
25. Verify the restore file paths under Restore the database files as. Update them if your SQL 

Server data directory is different: 
 

 
Data file (.mdf):  C:\Program Files\Microsoft SQL 
Server\MSSQL15.SQLEXPRESS\MSSQL\DATA\ xyz_db.mdf 
Log file  (.ldf):  C:\Program Files\Microsoft SQL 
Server\MSSQL15.SQLEXPRESS\MSSQL\DATA\ xyz_db_log.ldf 

 

26. Click OK to start the restore 
27. Wait for the completion message: Database 'Xyz_db' restored successfully 
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  ✓  The database is now fully restored with all tables, stored procedures, and demo data. You do not 
need to run any SQL scripts separately. 

 

Method B: Restore via T-SQL Command (Advanced) 

If you prefer the command line or are scripting a deployment, open a New Query window in 
SSMS connected to the master database and run: 

 

 
RESTORE DATABASE [Xyz_db] 
FROM DISK = N'C:\Projects\ExtremeOffice\app\xyz_db.bak' 
WITH 
  MOVE N'Xyz_db' 
    TO N'C:\Program Files\Microsoft SQL Server\MSSQL15.SQLEXPRESS\MSSQL\DATA\ 
xyz_db.mdf', 
  MOVE N'Xyz_db_log' 
    TO N'C:\Program Files\Microsoft SQL Server\MSSQL15.SQLEXPRESS\MSSQL\DATA\ 
xyz_db_log.ldf', 
  REPLACE, 
  STATS = 10; 
GO 

 

 

  💡 PATH NOTE    The MSSQL15.SQLEXPRESS folder name corresponds to SQL Server 2019 
Express. If you are using a named instance or a different version, the path will differ — check your actual 
SQL Server data directory in SSMS under Server Properties → Database Settings. 

 

  💡 INSTANCE NAME    If your instance is not SQLEXPRESS (e.g. it is a default instance), replace 
MSSQL15.SQLEXPRESS with MSSQL15.MSSQLSERVER or the correct instance folder name. 

 

  ⚠  WARNING    If you receive error 'Exclusive access could not be obtained because the database is in 
use', ensure no other applications are connected to Xyz_db. In SSMS, right-click the database → Tasks 
→ Take Offline, then retry the restore. 

 

After Restore: Verify the Database 

28. In SSMS Object Explorer, expand Databases — you should see the database listed 
29. Expand the database → Tables — you should see 80+ tables 
30. Right-click the Users table → Select Top 1000 Rows — at least one admin user record 

should be present 
31. Expand Stored Procedures — a full set of stored procedures should be visible 

 

  ✓  If all tables and stored procedures are present, the restore was successful. Proceed to Step 4. 

 

  🔁 ALTERNATIVE    If you do not have the .bak file or prefer a clean database, you may instead create 
an empty database named Xyz_db and run the included CoreAccBasicsScript.sql script to build the 
schema from scratch. 
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4 
Open the Project in Visual Studio 
Load the solution file and restore all required packages. 

 

32. Open Visual Studio 2022 
33. Click File → Open → Project/Solution 
34. Navigate to your extracted folder and select the .csproj or .sln file 
35. Wait for Visual Studio to load the project (first load may take 1–2 minutes) 
36. If prompted about NuGet package restore, click Restore 
37. Check the Solution Explorer panel — you should see the full project tree with all ASPX 

pages 

 

  💡 TIP    If Solution Explorer is not visible, open it via View → Solution Explorer or press Ctrl+Alt+L 

 

5 
Configure the Database Connection 
Update Web.config to point to your SQL Server instance and database. 

 

In Solution Explorer, find and open Web.config in the project root. Locate the 
<connectionStrings> section and update it: 

 

 
<connectionStrings> 
  <add name="XerpCon" 
       connectionString="data source=YOUR_SERVER_NAME; 
                         initial catalog=Xyz_db; 
                         user id=YOUR_SQL_USERNAME; 
                         password=YOUR_SQL_PASSWORD; 
                         MultipleActiveResultSets=True" 
       providerName="System.Data.SqlClient" /> 
</connectionStrings> 

 

 

Replace the placeholders as follows: 

YOUR_SERVER_NAME Your SQL Server instance name. For local Express 
installs, use: .\SQLEXPRESS 

Xyz_db The database name you restored in Step 3 (default: 
Xyz_db) 

YOUR_SQL_USERNAME Your SQL Server login username (or use Integrated 
Security=True for Windows auth) 

YOUR_SQL_PASSWORD Your SQL Server login password 
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  💡 WINDOWS AUTH    If using Windows Authentication instead of a SQL login, replace user id=... 
password=... with: Integrated Security=True 

 

6 
Run the Application Locally 
Launch the site using Visual Studio's built-in development server. 

 

38. In Visual Studio, press F5 or click the green Run (IIS Express) button in the toolbar 
39. Visual Studio will build the project and open your default browser automatically 
40. The login page will appear at: http://localhost:[port]/login.aspx 
41. Log in with the default administrator credentials: 
 

Super Administrator: 

Username rony 

Password demo2026 

 
Branch Administrator: 

Username rony 

Password demo2026 

  ⚠  WARNING    Change the default admin password immediately after your first login. Go to Users & 
Security → User Profile → Reset Password. 

 

  ✓  If the dashboard loads successfully, the database connection is working correctly and your local 
setup is complete. 
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4. Initial System Configuration 
Before using the system for real business data, complete the following configuration steps from 
within the application. 

 

4.1 Company Setup 

42. Navigate to: Maintenance → Company → Company Info 
43. Enter your company name, address, phone, and email 
44. Upload your company logo (recommended: PNG, 300x100 px) 
45. Set your financial year start month 
46. Click Save 

 

4.2 VAT / Tax Setup 

47. Navigate to: Maintenance → Company → VAT Setup 
48. Enter your VAT registration number 
49. Set the applicable VAT rate (e.g. 15% for Saudi Arabia) 
50. Configure which product groups are VAT-applicable 
51. Click Save 

 

4.3 Chart of Accounts 

52. Navigate to: Core Accounting → Setups → Accounts Head Setup 
53. Review the pre-seeded chart of accounts 
54. Add, rename, or restructure accounts to match your business 
55. Set up Control Accounts and Subsidiary Accounts as needed 

 

  💡 TIP    The system comes with a standard chart of accounts pre-loaded. You only need to customize it 
— not build it from scratch. 

 

4.4 Warehouse Setup 

56. Navigate to: Store & Inventory → Warehouses → Warehouse Setup 
57. Create at least one warehouse (e.g. Main Warehouse) 
58. For multi-location businesses, add each warehouse separately 
59. Assign warehouse managers if applicable 
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4.5 User Accounts & Security 

60. Navigate to: Users & Security → User Profile 
61. Create individual user accounts for each staff member 
62. Navigate to: Users & Security → Menu Level Security — restrict menu access per user 
63. Navigate to: Users & Security → Form Level Security — restrict individual screens per 

user 
64. Assign each user to their appropriate department and role 

 

  ⚠  WARNING    Never share the admin account with regular users. Create named individual accounts 
for each employee so that the audit trail (Login History) is meaningful. 

 

4.6 Email & SMS Gateways (Optional) 

65. Navigate to: Maintenance → Email Settings to configure your SMTP server 
66. Navigate to: Maintenance → SMS Gateway → SMS Gateway Setup to connect your SMS 

provider 
67. Test both by sending a test message before going live 
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5. Production Deployment on IIS 
Once the application works correctly on your local machine, follow these steps to deploy it to a 
Windows Server running IIS for production use or to share with your team. 

 

5.1 Prepare the Windows Server 

68. Log in to your Windows Server (2016, 2019, or 2022 recommended) 
69. Open Server Manager → Add Roles and Features 
70. Select: Web Server (IIS) 
71. Expand IIS and ensure the following features are checked: 
• Common HTTP Features: Static Content, Default Document, Directory Browsing, HTTP 

Errors 
• Application Development: ASP.NET 4.8, .NET Extensibility 4.8, ISAPI Extensions, ISAPI 

Filters 
• Security: Basic Authentication, Windows Authentication 
• Management Tools: IIS Management Console 
72. Complete the installation and restart if prompted 

 

5.2 Install .NET Framework 4.7.2 on the Server 

73. Download the .NET Framework 4.7.2 offline installer from Microsoft 
74. Run the installer on the server 
75. Restart the server after installation 
76. Verify: Open a command prompt and run: reg query "HKLM\SOFTWARE\Microsoft\NET 

Framework Setup\NDP\v4\Full" /v Release 

 

5.3 Install SQL Server on the Server 

77. Download SQL Server 2019 Express (free) or Standard (licensed) for production 
78. Run the installer and select Default Instance or a named instance 
79. Enable SQL Server Authentication mode (Mixed Mode) 
80. Set a strong sa password and note it 
81. Ensure the SQL Server Browser service is running 

 

  💡 CLOUD TIP    If using Azure SQL Database or Amazon RDS, skip the SQL Server install. Just 
update the connection string in Web.config with your cloud database endpoint. 

 

5.4 Publish the Application 
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82. Back on your development PC, open the project in Visual Studio 
83. Right-click the project in Solution Explorer → Publish 
84. Choose Folder as the publish target 
85. Set the output path to: C:\PublishOutput\ExtremeOffice 
86. Click Publish and wait for the build to complete 
87. Copy the contents of C:\PublishOutput\ExtremeOffice to your server (via RDP, FTP, or 

shared drive) 
88. Place the files at: C:\inetpub\wwwroot\ExtremeOffice\  on the server 

 

5.5 Create the IIS Website 

89. On the server, open IIS Manager (search inetmgr in the Start menu) 
90. In the left panel, expand the server node → right-click Sites → Add Website 
91. Fill in the details: 

Site name ExtremeOffice 

Physical path C:\inetpub\wwwroot\ExtremeOffice 

Port 80 (or 443 for HTTPS) 

Host name your-domain.com (optional) 

92. Click OK to create the site 
93. In the left panel, click the new site → Application Pool (on the right) 
94. Set the Application Pool to use: .NET CLR Version 4.0, Integrated Pipeline Mode 

 

5.6 Configure Permissions 

95. Right-click the ExtremeOffice folder in File Explorer → Properties → Security 
96. Click Edit → Add and add the IIS_IUSRS group 
97. Grant Read, Write, and Modify permissions 
98. Also add NETWORK SERVICE with Read & Execute permissions 
99. Click Apply → OK 

 

  ⚠  WARNING    Without correct folder permissions, the application will throw 500 errors when trying to 
write temporary files, session state, or generate reports. 

 

5.7 Update Web.config on the Server 

100. Open the Web.config file in the server's application folder 
101. Update the connectionStrings section with the server's SQL Server name and credentials 

(same as Step 5 in development) 
102. Save the file 
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5.8 Set Up HTTPS / SSL (Strongly Recommended) 

103. Obtain an SSL certificate — Let's Encrypt (free) via Win-ACME, or purchase a commercial 
cert 

104. In IIS Manager, select your site → Bindings → Add 
105. Choose HTTPS, port 443, and select your SSL certificate 
106. Add a redirect from HTTP to HTTPS: create a URL Rewrite rule or use a simple redirect in 

web.config 

 

  💡 SECURITY    HTTPS is not optional for production. All login credentials and session data should be 
transmitted over an encrypted connection. 

 

  



Extreme Office ERP  —  Setup & Deployment Guide Alwajeez Tech 

alwajeeztech.com  |  sales@alwajeeztech.com  |  +966 55 894 7166 Page 17 

6. Crystal Reports Runtime 
Extreme Office uses SAP Crystal Reports Runtime 13.0.4000 SP29 for all 150+ built-in reports. 
This exact version must be installed on every machine that runs the application — both 
development PCs and production servers. 

 

  ⚠  WARNING    The version must be SAP Crystal Reports Runtime 13.0.4000 SP29 specifically. 
Installing an earlier service pack (e.g. SP20, SP25) or a later one will cause report failures. Always verify 
the version number after installation. 

 

6.1 Install the Crystal Reports Runtime 

107. Locate the Crystal Reports runtime installer in the source package: 
 

 
C:\Projects\ExtremeOffice\bin\CRRuntime\ 
  → CRRuntime_13_0_4000_SP29_x64.msi   (for 64-bit systems — recommended) 
  → CRRuntime_13_0_4000_SP29_x86.msi   (for 32-bit systems only) 

 

108. Copy the installer to the target machine if deploying to a server 
109. Right-click the .msi file → Run as Administrator 
110. Accept the license agreement and follow all default prompts 
111. Complete the installation — no reboot is required, but it is recommended 
112. After installation, reset IIS by opening a Command Prompt (as Administrator) and running: 

 

 
iisreset 

 

 

  💡 VERIFY VERSION    To confirm the correct version is installed, open Windows Control Panel → 
Programs → Programs and Features. Look for SAP Crystal Reports Runtime Engine for .NET Framework 
and verify the version shows 13.0.4000.xxxx 

 

  ⚠  WARNING    If Crystal Reports is not installed on the server, all reports will fail with a runtime error. If 
the wrong service pack is installed, some reports may render incorrectly or crash. This is the most 
common production deployment issue. 

 

7. Verify the Deployment 
Run through this checklist after deployment to confirm everything is working correctly. 
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Deployment Checklist 

Login page loads Browse to your server IP or domain — the login page 
should appear immediately 

Admin login works Log in with admin credentials — dashboard should 
display with no errors 

Database connection Navigate to any data entry screen — if data loads, 
the DB connection is good 

A report generates Go to Core Accounting → Reports → Trial Balance — 
click View — report should render 

PDF export works On any report, click Export → PDF — file should 
download cleanly 

Excel export works On any report, click Export → Excel — .xlsx file 
should download 

User creation works Create a test user in Users & Security — log out 
and log in as that user 

Company name shows 
correctly 

Your company name and logo appear in the top 
navigation 

HTTPS working Browser shows padlock icon — no mixed-content 
warnings 
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8. Customization Quick Reference 
The codebase is modular and clean — every major customization has a clear entry point. The 
table below maps common tasks to the relevant files. 

 

Key Files and Where to Make Changes 

What You Want to Change Where to Look 

Navigation menu items MenuStructure.aspx  or  MasterPage.Master 

Add a new data entry screen Copy any existing .aspx page as a template, 
update the code-behind (.aspx.cs) 

Add a new report Crystal Reports Designer → create new .rpt file 
→ add a viewer page 

Modify financial logic App_Code/Accounting.cs 

Change user permissions logic App_Code/XERPSecurity.cs  +  database permission 
tables 

Modify theme / colours /css/Dashboard.css  and  /App_Themes/Blue/ 
folder 

Add a new database table SQL Server → add table → update XerpDataSet.xsd 
in VS DataSet Designer 

Company logo / branding Maintenance → Company Info (in-app)  or  
/images/ folder 

Email templates Communication module → Email Templates (in-app, 
CKEditor-powered) 

SMS gateway provider Maintenance → SMS Gateway Settings (in-app) 

 

  🤖 AI AGENTS    The codebase is well-structured for AI-assisted modification. You can share relevant 
files with Claude Code, Cursor, or GitHub Copilot and describe exactly what you want changed — the 
consistent naming conventions and modular page structure make AI edits highly reliable. 
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9. Automated Setup Script 
For experienced users and server administrators, a PowerShell script is included that automates 
the entire deployment process — from IIS installation through to the smoke test — in a single 
command. 

The script is named setup-script.ps1 and is located in the root of your downloaded package. 

 

9.1 What the Script Does Automatically 

Running the script executes the following 13 steps without any manual intervention: 

 

# Step Details 

1 Pre-flight Checks Validates OS version (Win 10 / Server 2019+), 64-bit arch, 
PowerShell 5.1+, admin rights, source path, and BAK file 
presence 

2 IIS Installation Installs the Web Server role with all required features: 
ASP.NET 4.5, ISAPI extensions, authentication modules, and 
management console 

3 .NET Framework 4.7.2 Checks registry release key; downloads and installs silently if 
not present 

4 SQL Server 2019 Express Detects if the instance is reachable; downloads and silently 
installs SQL Server 2019 Express if not found 

5 Database Restore Auto-discovers SQL data directory, reads logical file names 
from XO_DB.bak, then restores with MOVE and REPLACE. 
Falls back to CoreAccBasicsScript.sql if needed 

6 Crystal Reports SP29 Finds the MSI in /bin/CRRuntime/ and runs a silent install via 
msiexec /quiet 

7 Deploy Application Files Copies the /app folder to the IIS deployment path 

8 Patch Web.config Backs up the original Web.config then updates the XerpCon 
connection string for Windows or SQL authentication 

9 Application Pool Creates ExtremeOfficePool with .NET CLR v4.0, Integrated 
Pipeline, Always Running, no idle timeout 

10 IIS Website Creates and starts the IIS website on the specified port, sets 
login.aspx as the default document 

11 Folder Permissions Grants Modify rights to IIS_IUSRS, NETWORK SERVICE, 
and the app pool identity; also sets Windows Temp folder 
rights for Crystal Reports 

12 IIS Reset & Smoke Test Runs iisreset and sends an HTTP request to /login.aspx, 
reporting the response code 
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# Step Details 

13 Summary Report Prints a formatted summary with URL, credentials, config 
values, all warnings, errors, and next steps. Writes a 
timestamped log to %TEMP% 

 

9.2 Prerequisites Before Running the Script 

• Windows 10 (64-bit) or Windows Server 2019 or later 
• PowerShell 5.1 or later (pre-installed on Windows 10 / Server 2019) 
• Run PowerShell as Administrator (right-click → Run as Administrator) 
• Internet connection (for downloading SQL Server Express and .NET Framework if not 

already installed) 
• The Extreme Office package extracted to a local folder (e.g. C:\Projects\ExtremeOffice) 

 

  ⚠  WARNING    The script must be run as Administrator. It will exit immediately with an error if launched 
without elevated privileges. 

 

9.3 Execution Policy 

Windows PowerShell blocks unsigned scripts by default. Before running the script, set the 
execution policy for the current session: 

 

 
# Run this in PowerShell (as Administrator) before executing the setup script: 
Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope Process 

 

 

  💡 SCOPE    Using -Scope Process applies the policy only to the current PowerShell session and does 
not permanently change system settings — the safest approach. 

 

9.4 Usage Examples 

Example 1 — Interactive Mode (Recommended for First-Time Use) 

Prompts for confirmation at each significant step and any missing values. Safe for first-time users. 

 

 
.\Setup-ExtremeOffice.ps1 -SourcePath "C:\Projects\ExtremeOffice" 
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Example 2 — Fully Unattended with Windows Authentication 

No prompts. Uses Windows (Integrated) Authentication for the database connection — the 
simplest and most secure option for local installs. 

 

 
.\Setup-ExtremeOffice.ps1 ` 
    -SourcePath  "C:\Projects\ExtremeOffice" ` 
    -SqlInstance ".\SQLEXPRESS" ` 
    -SqlAuthMode Windows ` 
    -Unattended 

 

 

Example 3 — Unattended with SQL Server Authentication 

Uses a named SQL login. The password can alternatively be passed via the environment variable 
XOERP_SQL_PASSWORD to avoid it appearing in shell history. 

 

 
.\Setup-ExtremeOffice.ps1 ` 
    -SourcePath  "D:\Packages\ExtremeOffice" ` 
    -SqlInstance "MYSERVER\SQLEXPRESS" ` 
    -SqlAuthMode SQL ` 
    -SqlUser     "erp_user" ` 
    -SqlPassword "MyStr0ngP@ss!" ` 
    -SitePort    8080 ` 
    -Unattended 

 

 

Example 4 — Skip Steps Already Completed 

If SQL Server and IIS are already installed and configured, skip those steps to avoid unnecessary 
changes: 

 

 
.\Setup-ExtremeOffice.ps1 ` 
    -SourcePath     "C:\Projects\ExtremeOffice" ` 
    -SkipSqlInstall ` 
    -SkipIisInstall ` 
    -Unattended 

 

 

9.5 All Available Parameters 

Parameter Default Description 

-SourcePath C:\Projects\ExtremeOffice Path to the extracted package folder (must 
contain /app subfolder) 
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Parameter Default Description 

-SiteName ExtremeOffice Name for the IIS website 

-SitePort 80 HTTP port for the IIS site binding 

-DeployPath C:\inetpub\wwwroot\ExtremeOffice Target folder for deployed application files 

-SqlInstance .\SQLEXPRESS SQL Server instance name to connect to 

-SqlDbName Xyz_db Name to assign to the restored database 

-SqlAuthMode Windows Authentication mode: Windows 
(Integrated) or SQL (username + 
password) 

-SqlUser (none) SQL Server login username — only used 
when SqlAuthMode is SQL 

-SqlPassword (none) SQL Server login password — can also be 
set via XOERP_SQL_PASSWORD 
environment variable 

-SkipSqlInstall Off Switch: skip SQL Server installation if 
already installed 

-SkipIisInstall Off Switch: skip IIS installation if already 
configured 

-
SkipCrystalInstall 

Off Switch: skip Crystal Reports Runtime 
installation 

-SkipDbRestore Off Switch: skip database restore (use if DB is 
already in place) 

-Unattended Off Switch: suppress all interactive prompts 
for fully automated deployment 

 

9.6 What to Do After the Script Completes 

113. Open the URL shown in the summary — typically: http://localhost/login.aspx 
114. Log in with the default credentials:  admin  /  admin123 
115. Change the admin password immediately: Users & Security → User Profile → Reset 

Password 
116. Go to Maintenance → Company Info and enter your company name, logo, and details 
117. Configure VAT Setup, Chart of Accounts, and Warehouses 
118. Verify Crystal Reports is version 13.0.4000 SP29 via Control Panel → Programs and 

Features 

 

  ⚠  WARNING    The script sets a temporary SA password of TempSetupAdmin@123! if it installs SQL 
Server. Change this immediately in SSMS: Security → Logins → sa → Properties → Change Password. 
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  📄 LOG FILE    The script writes a timestamped log to 
%TEMP%\ExtremeOffice_Setup_YYYYMMDD_HHmmss.log. If anything goes wrong, this is the first 
place to look. 
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10. Troubleshooting 
The following table covers the most common issues encountered during setup and their 
resolutions. 

 

Issue / Error Resolution 

Cannot connect to SQL Server Check the server name in Web.config. For local Express, use 
.\SQLEXPRESS. Ensure SQL Server Browser service is running. 
Check Windows Firewall is not blocking port 1433. 

HTTP 500 error on page load Usually a configuration or permission problem. Enable detailed 
errors in Web.config by setting customErrors mode='Off'. Check 
the Windows Event Log (Application) for the full error. 

Reports are blank or throw 
runtime error 

The SAP Crystal Reports runtime is not installed on the server. 
Install it from the /bin/CRRuntime/ folder in the source package, 
then run iisreset. 

PDF export fails Crystal Reports runtime not installed, or the IIS application pool 
user lacks write access to the Temp folder. Grant IIS_IUSRS write 
access to C:\Windows\Temp. 

Login fails with 'Invalid 
credentials' 

Ensure the CoreAccBasicsScript.sql ran successfully and created 
the Users table with seed data. In SSMS, run: SELECT * FROM 
Users to verify records exist. 

NuGet package restore errors 
in Visual Studio 

Go to Tools → NuGet Package Manager → Package Manager 
Console and run: Update-Package -reinstall. Or delete the 
/packages/ folder and let Visual Studio restore it. 

Pages load but show no data Database connection is working but you are pointing to a different 
database. Confirm the initial catalog name in Web.config matches 
the database you ran the script against in SSMS. 

IIS site shows 403 Forbidden Enable Directory Browsing in IIS, or ensure the default document 
(login.aspx) is listed under Default Documents in IIS Manager for 
the site. 

Crystal Reports error: 'Load 
report failed' 

The .rpt report files are missing or not copied to the server. 
Ensure the /Reports/ folder and all .rpt files are present in the 
deployed site folder. 
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11. Getting Further Help 

Live Demo Environment 

The live demo is available 24/7 for reference. If a feature works in the demo but not in your 
installation, the issue is in your local configuration, not the code. 

 

Demo URL https://xo.alzerp.com 

Username rony 

Password demo2026 

 

Expert Support from Alwajeez Tech 

The Exclusive Support Package ($19/hr) gives you direct access to the team who built this 
system. Support services include: 

• Remote server deployment and configuration 
• Live technical walkthrough sessions 
• Customization guidance and code review 
• Staff training sessions (live or recorded) 
• Ongoing technical Q&A 

 

Contact Alwajeez Tech 

sales@alwajeeztech.com   |   WhatsApp: +966 55 894 7166 

Al Hayat Commercial Center, Level-2, Suite #A216, Jeddah, KSA 

 

  📦 BOOK SUPPORT    Book the Expert Support Package online at: 
alwajeeztech.com/shop/product/exclusive-support-for-project-implementation-19-hr/ 


